[Important] Information on forced update